Mandriva Linux Security Advisory : automake (MDVSA-2013:031)

Medium Nessus Plugin ID 66045


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability has been discovered and corrected in automake :

A race condition in automake (lib/am/ could allow a local attacker to run arbitrary code with the privileges of the user running make distcheck (CVE-2012-3386).

The updated packages have been patched to correct this issue.

NOTE: This advisory was previousely given the MDVSA-2013:018 identifier by mistake.


Update the affected automake and / or automake1.7 packages.

Plugin Details

Severity: Medium

ID: 66045

File Name: mandriva_MDVSA-2013-031.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2013/04/20

Modified: 2013/11/25

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.4

Temporal Score: 3.8

Vector: CVSS2#AV:L/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:automake, p-cpe:/a:mandriva:linux:automake1.7, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/04/05

Reference Information

CVE: CVE-2012-3386

BID: 54418

MDVSA: 2013:031