Ekiga < 4.0.1 ptlib XML Expansion Recursion DoS

medium Nessus Plugin ID 66033
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The version of Ekiga installed on the remote host may be affected by a denial of service vulnerability.

Description

According to the version in its SIP banner, the installed version of Ekiga on the remote host is earlier than 4.0.1 and thus contains a version of the ptlib library that fails to conduct proper length checks during XML expansion. A remote, unauthenticated attacker could exploit this issue to consume extreme amounts of CPU and memory through the use of a specially crafted XML document.

Solution

Upgrade to Ekiga 4.0.1 or later.

See Also

https://gitlab.gnome.org/GNOME/ekiga/blob/EKIGA_4_0_1/NEWS

https://www.ekiga.org/news/2013-02-21/ekiga-4.0.1-stable-available

Plugin Details

Severity: Medium

ID: 66033

File Name: ekiga_4_0_1.nasl

Version: 1.4

Type: remote

Published: 4/19/2013

Updated: 11/15/2018

Dependencies: ekiga_detection.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:ekiga:ekiga

Required KB Items: ekiga/sip_detected, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2/21/2013

Vulnerability Publication Date: 3/15/2013

Reference Information

CVE: CVE-2013-1864

BID: 58520