Google Picasa < 3.9 Build 136.17 Multiple Vulnerabilities

High Nessus Plugin ID 65925


The photo organizer running on the remote Windows host has multiple vulnerabilities.


The version of Google Picasa running on the remote host is earlier than 3.9 Build 136.17. As such, it is affected by the following vulnerabilities:

- A buffer underflow vulnerability exists in the 'LZWDecodeCompat' function in the LibTIFF library. An attacker could exploit this issue through the use of a specially crafted TIFF image, potentially causing a denial of service. (CVE-2009-2285)

- A sign-extension flaw exists that is triggered by the 'biBitCount' field that is not properly validated when processing the BMP color table. An attacker could exploit this issue though a specially crafted BMP image, potentially causing a heap-based buffer overflow resulting in a denial of service or arbitrary code execution.


Upgrade to Picasa 3.9.0 build 136.17 or later.

See Also

Plugin Details

Severity: High

ID: 65925

File Name: google_picasa_3_9_136_17.nasl

Version: $Revision: 1.1 $

Type: local

Agent: windows

Family: Windows

Published: 2013/04/11

Modified: 2013/04/11

Dependencies: 45048

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:picasa

Required KB Items: SMB/Google_Picasa/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/03/14

Vulnerability Publication Date: 2013/03/14

Reference Information

CVE: CVE-2009-2285

BID: 35451, 58613

OSVDB: 55265, 91508

EDB-ID: 10205

CWE: 119