Debian DSA-2654-1 : libxslt - denial of service

Medium Nessus Plugin ID 65793

Synopsis

The remote Debian host is missing a security-related update.

Description

Nicolas Gregoire discovered that libxslt, an XSLT processing runtime library, is prone to denial of service vulnerabilities via crafted XSL stylesheets.

Solution

Upgrade the libxslt packages.

For the stable distribution (squeeze), this problem has been fixed in version 1.1.26-6+squeeze3.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=703933

https://packages.debian.org/source/squeeze/libxslt

https://www.debian.org/security/2013/dsa-2654

Plugin Details

Severity: Medium

ID: 65793

File Name: debian_DSA-2654.nasl

Version: 1.10

Type: local

Agent: unix

Published: 2013/04/04

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libxslt, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/04/03

Reference Information

CVE: CVE-2012-6139

BID: 58685

DSA: 2654