Eye-Fi Helper < 3.4.23 Directory Traversal

Low Nessus Plugin ID 65688


The remote Windows host has an application that is affected by a directory traversal vulnerability.


The version of Eye-Fi Helper installed on the remote host is a version prior to 3.4.23. It is, therefore, affected by a directory traversal vulnerability because it fails to properly sanitize user- supplied input.

An attacker could exploit this issue to overwrite arbitrary files on the vulnerable computer, which could result in a denial of service or arbitrary code execution.


Update to Eye-Fi Helper 3.4.23 or later.

See Also



Plugin Details

Severity: Low

ID: 65688

File Name: eyefi_helper_3_4_23.nasl

Version: $Revision: 1.2 $

Type: remote

Family: Web Servers

Published: 2013/03/26

Modified: 2017/02/07

Dependencies: 65687

Risk Information

Risk Factor: Low


Base Score: 2.9

Temporal Score: 2.4

Vector: CVSS2#AV:A/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:eye:eye-fi_helper

Required KB Items: www/eyefi_helper

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/01/04

Vulnerability Publication Date: 2013/01/04

Reference Information

CVE: CVE-2011-4696

BID: 57163

OSVDB: 88914