Fedora 17 : privoxy-3.0.21-1.fc17 (2013-3756)

Medium Nessus Plugin ID 65649


The remote Fedora host is missing a security update.


Common Vulnerabilities and Exposures assigned an identifier CVE-2013-2503 to the following vulnerability :

Privoxy before 3.0.21 does not properly handle Proxy-Authenticate and Proxy-Authorization headers in the client-server data stream, which makes it easier for remote HTTP servers to spoof the intended proxy service via a 407 (aka Proxy Authentication Required) HTTP status code.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected privoxy package.

See Also




Plugin Details

Severity: Medium

ID: 65649

File Name: fedora_2013-3756.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2013/03/22

Modified: 2015/10/19

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.8

Temporal Score: 4.5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:privoxy, cpe:/o:fedoraproject:fedora:17

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/03/12

Reference Information

CVE: CVE-2013-2503

BID: 58425

FEDORA: 2013-3756