MS KB2824670: Update for Vulnerabilities in Adobe Flash Player in Internet Explorer 10

critical Nessus Plugin ID 65222

Synopsis

The remote host has an ActiveX control installed that is potentially affected by multiple vulnerabilities.

Description

The remote host is missing KB2824670. It may, therefore, be affected by the following vulnerabilities related to the installed version of the Adobe Flash ActiveX control :

- An integer overflow error exists that could lead to code execution. (CVE-2013-0646)

- A use-after-free error exists that could lead to code execution. (CVE-2013-0650)

- A memory corruption error exists that could lead to code execution. (CVE-2013-1371)

- A heap-based buffer overflow error exists that could lead to code execution. (CVE-2013-1375)

Solution

Install Microsoft KB2824670.

See Also

http://www.adobe.com/support/security/bulletins/apsb13-09.html

https://docs.microsoft.com/en-us/security-updates/SecurityAdvisories/2016/2755801

https://support.microsoft.com/en-us/help/2824670/microsoft-security-advisory-update-for-vulnerabilities-in-adobe-flash

Plugin Details

Severity: Critical

ID: 65222

File Name: smb_kb2824670.nasl

Version: 1.10

Type: local

Agent: windows

Family: Windows

Published: 3/13/2013

Updated: 11/27/2019

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2013-1375

Vulnerability Information

CPE: cpe:/o:microsoft:windows, cpe:/a:adobe:flash_player

Required KB Items: SMB/Registry/Enumerated, SMB/WindowsVersion, SMB/ProductName

Exploit Ease: No known exploits are available

Patch Publication Date: 3/12/2013

Vulnerability Publication Date: 3/12/2013

Reference Information

CVE: CVE-2013-0646, CVE-2013-0650, CVE-2013-1371, CVE-2013-1375

BID: 58436, 58438, 58439, 58440

MSKB: 2824670