Firefox ESR 17.x < 17.0.4 nsHTMLEditor Use-After-Free (Mac OS X)

High Nessus Plugin ID 65128


The remote Mac OS X host contains a web browser that is potentially affected by a use-after-free vulnerability.


The installed version of Firefox ESR 17.x is earlier than 17.0.4 and thus, is potentially affected by a use-after-free vulnerability.

An error exists in the HTML editor (nsHTMLEditor) related to content script and the calling of the function 'document.execCommand' while internal editor operations are running. The previously freed memory can be dereferenced and could lead to arbitrary code execution.


Upgrade to Firefox 17.0.4 ESR or later.

See Also

Plugin Details

Severity: High

ID: 65128

File Name: macosx_firefox_17_0_4_esr.nasl

Version: $Revision: 1.10 $

Type: local

Agent: macosx

Published: 2013/03/08

Modified: 2017/05/16

Dependencies: 55417

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox_esr

Required KB Items: MacOSX/Firefox/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/03/07

Vulnerability Publication Date: 2013/03/07

Reference Information

CVE: CVE-2013-0787

BID: 58391

OSVDB: 90928