PHP 5.4.x < 5.4.12 Information Disclosure

Medium Nessus Plugin ID 64993

Synopsis

The remote web server uses a version of PHP that is potentially
affected by an information disclosure vulnerability.

Description

According to its banner, the version of PHP 5.4.x installed on the
remote host is prior to 5.4.12. It is, therefore, potentially
affected by an information disclosure in the file 'ext/soap/php_xml.c'
related to parsing SOAP 'wsdl' files and external entities that could
cause PHP to parse remote XML documents defined by an attacker. This
could allow access to arbitrary files. (CVE-2013-1824)

Note that this plugin does not attempt to exploit the vulnerabilities
but, instead relies only on PHP's self-reported version number.

Solution

Upgrade to PHP version 5.4.12 or later.

See Also

http://www.php.net/ChangeLog-5.php#5.4.12

http://www.nessus.org/u?2dcf53bd

http://www.nessus.org/u?889595b1

Plugin Details

Severity: Medium

ID: 64993

File Name: php_5_4_12.nasl

Version: 1.9

Type: remote

Family: CGI abuses

Published: 2013/03/04

Modified: 2019/01/03

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2013-1824

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Vulnerability Information

CPE: cpe:/a:php:php

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2013/02/21

Vulnerability Publication Date: 2013/02/21

Reference Information

CVE: CVE-2013-1824

BID: 62373