PHP 5.3.x < 5.3.22 Multiple Vulnerabilities

High Nessus Plugin ID 64992

Synopsis

The remote web server uses a version of PHP that is potentially
affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP 5.3.x installed on the
remote host is prior to 5.3.22. It is, therefore, potentially
affected by the following vulnerabilities :

- An error exists in the file 'ext/soap/soap.c'
related to the 'soap.wsdl_cache_dir' configuration
directive and writing cache files that could allow
remote 'wsdl' files to be written to arbitrary
locations. (CVE-2013-1635)

- An error exists in the file 'ext/soap/php_xml.c'
related to parsing SOAP 'wsdl' files and external
entities that could cause PHP to parse remote XML
documents defined by an attacker. This could allow
access to arbitrary files. (CVE-2013-1643)

Note that this plugin does not attempt to exploit the vulnerabilities
but, instead relies only on PHP's self-reported version number.

Solution

Upgrade to PHP version 5.3.22 or later.

See Also

http://www.nessus.org/u?2dcf53bd

http://www.nessus.org/u?889595b1

http://www.php.net/ChangeLog-5.php#5.3.22

Plugin Details

Severity: High

ID: 64992

File Name: php_5_3_22.nasl

Version: 1.13

Type: remote

Family: CGI abuses

Published: 2013/03/04

Modified: 2018/09/17

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2013-1635

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2013/02/21

Vulnerability Publication Date: 2013/02/21

Reference Information

CVE: CVE-2013-1635, CVE-2013-1643

BID: 58224, 58766