WP Symposium Plugin for WordPress 'symposium_groups_functions.php' 'gid' Parameter SQL Injection

high Nessus Plugin ID 64895

Synopsis

The remote web server hosts a web application that is affected by a SQL injection vulnerability.

Description

The WordPress WP Symposium Plugin installed on the remote host is affected by a SQL injection vulnerability due to a failure to properly sanitize user-supplied input to the 'gid' parameter of the 'symposium_groups_functions.php' script. An unauthenticated, remote attacker can leverage this issue to launch a SQL injection attack against the affected application, leading to manipulation of data in the back-end database or the disclosure of arbitrary data.

The application is also reportedly affected by several additional SQL injection vulnerabilities although Nessus has not tested for these.

Solution

Upgrade to WP Symposium Plugin version 12.12 or later.

See Also

http://ceriksen.com/2013/02/18/wp-symposium-multiple-sql-injection/

Plugin Details

Severity: High

ID: 64895

File Name: wordpress_wp_symposium_gid_sql_injection.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 2/26/2013

Updated: 6/5/2024

Supported Sensors: Nessus

Risk Information

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/a:wpsymposium:wp_symposium, cpe:/a:wordpress:wordpress

Required KB Items: installed_sw/WordPress, www/PHP

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: true

Exploit Ease: Exploits are available

Exploited by Nessus: true

Patch Publication Date: 11/23/2012

Vulnerability Publication Date: 1/21/2013

Reference Information

BID: 57478