WordPress Poll Plugin 'poll_id' Parameter SQL Injection

high Nessus Plugin ID 64894

Synopsis

The remote web server hosts a web application that is affected by a SQL injection vulnerability.

Description

The WordPress Poll Plugin installed on the remote host is affected by a SQL injection vulnerability due to a failure to properly sanitize user-supplied input to the 'poll_id' parameter of the 'wp-admin/admin-ajax.php' script. An unauthenticated, remote attacker can leverage this issue to launch a SQL injection attack against the affected application, leading to manipulation of data in the backend database or the disclosure of arbitrary data.

The application is also reportedly affected by several additional SQL injection vulnerabilities; however, Nessus has not tested for these.

Solution

Either upgrade to version 34.05 or later, or remove the plugin.

Note that the plugin is currently not available through the WordPress.org Plugin Directory.

See Also

http://www.nessus.org/u?98bc791e

Plugin Details

Severity: High

ID: 64894

File Name: wordpress_poll_poll_id_sql_injection.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 2/26/2013

Updated: 6/4/2024

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: installed_sw/WordPress, www/PHP

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Ease: No exploit is required

Exploited by Nessus: true

Patch Publication Date: 1/16/2013

Vulnerability Publication Date: 1/21/2013

Reference Information

CVE: CVE-2013-1400

BID: 57630