Nagios XI 2011R1.9 Multiple SQL Injection Vulnerabilities

Medium Nessus Plugin ID 64690

Synopsis

The remote host has a web application installed that is affected by several SQL injection vulnerabilities.

Description

The remote host is running Nagios XI 2011R1.9. This version is reportedly affected by multiple SQL injection vulnerabilities in the 'hostgroups.php', 'services.php', 'hosts.php', and 'servicegroups.php' scripts.

Note that exploitation requires that an attacker to be authenticated.

Solution

Upgrade to Nagios XI CCM 2012 Full Beta or higher.

See Also

http://www.nessus.org/u?017d663e

https://seclists.org/bugtraq/2012/Jul/10

https://seclists.org/bugtraq/2012/Nov/116

http://labs.nagios.com/2012/04/13/nagios-xi-ccm-full-beta/

Plugin Details

Severity: Medium

ID: 64690

File Name: nagiosxi_2011r1_9_sqli.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 2013/02/19

Updated: 2018/11/15

Dependencies: 49774

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.5

Temporal Score: 5.4

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:nagios:nagios_xi

Required KB Items: www/nagios_xi

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/06/07

Vulnerability Publication Date: 2012/11/30

Reference Information

BID: 56761