OpenSSL 1.0.1 < 1.0.1d Multiple Vulnerabilities

Low Nessus Plugin ID 64534

Synopsis

The remote host may be affected by multiple vulnerabilities.

Description

According to its banner, the remote web server is running a version of OpenSSL 1.0.1 prior to 1.0.1d. The OpenSSL library is, therefore, reportedly affected by the following vulnerabilities :

- An error exists related to AES-NI, TLS 1.1, TLS 1.2 and the handling of CBC ciphersuites that could allow denial of service attacks. Note that platforms and versions that do not support AES-NI, TLS 1.1, or TLS 1.2 are not affected. (CVE-2012-2686)

- An error exists related to the handling of OCSP response verification that could allow denial of service attacks.
(CVE-2013-0166)

- An error exists related to the SSL/TLS/DTLS protocols, CBC mode encryption and response time. An attacker could obtain plaintext contents of encrypted traffic via timing attacks. (CVE-2013-0169)

Solution

Upgrade to OpenSSL 1.0.1d or later.

See Also

https://www.openssl.org/news/secadv/20130204.txt

Plugin Details

Severity: Low

ID: 64534

File Name: openssl_1_0_1d.nasl

Version: 1.19

Type: remote

Family: Web Servers

Published: 2013/02/09

Updated: 2019/12/04

Dependencies: 57323

Risk Information

Risk Factor: Low

CVSS Score Source: CVE-2013-0169

CVSS v2.0

Base Score: 2.6

Temporal Score: 1.9

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/02/05

Vulnerability Publication Date: 2013/02/04

Reference Information

CVE: CVE-2012-2686, CVE-2013-0166, CVE-2013-0169

BID: 57755, 57778, 60268