OpenSSL 1.0.1 < 1.0.1d Multiple Vulnerabilities

Medium Nessus Plugin ID 64534


The remote host may be affected by multiple vulnerabilities.


According to its banner, the remote web server is running a version of OpenSSL 1.0.1 prior to 1.0.1d. The OpenSSL library is, therefore, reportedly affected by the following vulnerabilities :

- An error exists related to AES-NI, TLS 1.1, TLS 1.2 and the handling of CBC ciphersuites that could allow denial of service attacks. Note that platforms and versions that do not support AES-NI, TLS 1.1, or TLS 1.2 are not affected. (CVE-2012-2686)

- An error exists related to the handling of OCSP response verification that could allow denial of service attacks.

- An error exists related to the SSL/TLS/DTLS protocols, CBC mode encryption and response time. An attacker could obtain plaintext contents of encrypted traffic via timing attacks. (CVE-2013-0169)


Upgrade to OpenSSL 1.0.1d or later.

See Also

Plugin Details

Severity: Medium

ID: 64534

File Name: openssl_1_0_1d.nasl

Version: $Revision: 1.17 $

Type: remote

Family: Web Servers

Published: 2013/02/09

Modified: 2016/05/12

Dependencies: 57323

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:ND/RC:ND

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/02/05

Vulnerability Publication Date: 2013/02/04

Reference Information

CVE: CVE-2012-2686, CVE-2013-0166, CVE-2013-0169

BID: 57755, 57778, 60268

OSVDB: 89848, 89849, 89865, 89866