Samba < 3.5.21 / 3.6.12 / 4.0.2 SWAT Multiple Vulnerabilities

Medium Nessus Plugin ID 64459

Synopsis

The remote Samba server is affected by multiple vulnerabilities.

Description

According to its banner, the version of Samba running on the remote host is 3.5.x prior to 3.5.21, 3.6.x prior to 3.6.12, or 4.x prior to 4.0.1. It is, therefore, affected by the following vulnerabilities :

- An unspecified flaw exists in the Samba Web Administration Tool (SWAT) that allows a remote attacker to conduct clickjacking attacks via a FRAME or IFRAME element. (CVE-2013-0213)

- A cross-site request forgery vulnerability exists due to a failure to require multiple steps or explicit confirmation for sensitive transactions in the Samba Web Administration Tool (SWAT). A remote attacker can exploit this, by convincing a user to follow a crafted URL, to cause the user to perform unintended actions.
(CVE-2013-0213)

Note that these vulnerabilities are only exploitable when SWAT is enabled, and it is not enabled by default. Additionally, note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Samba version 3.5.21 / 3.6.12 / 4.0.2 or later.
Alternatively, install the patch referenced in the vendor advisory.

See Also

https://www.samba.org/samba/security/CVE-2013-0213.html

https://www.samba.org/samba/security/CVE-2013-0214.html

https://www.samba.org/samba/history/samba-4.0.2.html

Plugin Details

Severity: Medium

ID: 64459

File Name: samba_4_0_2.nasl

Version: 1.11

Type: remote

Family: Misc.

Published: 2013/02/04

Updated: 2018/11/15

Dependencies: 10785

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.1

Temporal Score: 3.8

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/01/30

Vulnerability Publication Date: 2013/01/30

Reference Information

CVE: CVE-2013-0213, CVE-2013-0214

BID: 57631