Samba < 3.5.21 / 3.6.12 / 4.0.2 SWAT Multiple Vulnerabilities
Medium Nessus Plugin ID 64459
SynopsisThe remote Samba server is affected by multiple vulnerabilities.
DescriptionAccording to its banner, the version of Samba running on the remote
host is 3.5.x prior to 3.5.21, 3.6.x prior to 3.6.12, or 4.x prior to
4.0.1. It is, therefore, affected by the following vulnerabilities :
- An unspecified flaw exists in the Samba Web
Administration Tool (SWAT) that allows a remote attacker
to conduct clickjacking attacks via a FRAME or IFRAME
- A cross-site request forgery vulnerability exists due to
a failure to require multiple steps or explicit
confirmation for sensitive transactions in the Samba
Web Administration Tool (SWAT). A remote attacker can
exploit this, by convincing a user to follow a crafted
URL, to cause the user to perform unintended actions.
Note that these vulnerabilities are only exploitable when SWAT is
enabled, and it is not enabled by default. Additionally, note that
Nessus has not tested for these issues but has instead relied only on
the application's self-reported version number.
SolutionUpgrade to Samba version 3.5.21 / 3.6.12 / 4.0.2 or later.
Alternatively, install the patch referenced in the vendor advisory.