Ekiga < 4.0.0 Invalid UTF-8 Character Connection Data Parsing DoS

medium Nessus Plugin ID 64458
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The version of Ekiga installed on the remote host may be affected by a denial of service vulnerability.

Description

According to the version in its SIP banner, the version of Ekiga running on the remote host is potentially affected by a vulnerability that could allow a remote, unauthenticated attacker to cause a denial of service via invalid UTF-8 characters in the remote user's connection data.

Solution

Upgrade to Ekiga 4.0.0 or later.

See Also

https://gitlab.gnome.org/GNOME/ekiga/blob/EKIGA_4_0_0/NEWS

https://bugzilla.gnome.org/show_bug.cgi?id=653009

Plugin Details

Severity: Medium

ID: 64458

File Name: ekiga_4_0_0.nasl

Version: 1.8

Type: remote

Published: 2/4/2013

Updated: 12/4/2019

Dependencies: ekiga_detection.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2012-5621

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:ekiga:ekiga

Required KB Items: ekiga/sip_detected, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 10/20/2012

Vulnerability Publication Date: 6/20/2011

Reference Information

CVE: CVE-2012-5621

BID: 56790