WordPress < 3.5.1 Multiple Vulnerabilities

Medium Nessus Plugin ID 64452


The remote web server contains a PHP application that is affected by multiple vulnerabilities.


According to its version number, the WordPress install hosted on the remote web server is affected by multiple vulnerabilities :

- The application is affected by a server-side request forgery vulnerability in the 'pingback.ping' method used in 'xmlrpc.php'. This vulnerability can be used to expose information and remotely port scan a host using pingbacks. (CVE-2013-0235)

- The application is affected by two instances of cross-site scripting (XSS) attacks via shortcodes and post content. (CVE-2013-0236)

- The application is affected by a cross-site scripting (XSS) vulnerability in the Plupload external library.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to WordPress 3.5.1 or later.

See Also






Plugin Details

Severity: Medium

ID: 64452

File Name: wordpress_3_5_1.nasl

Version: 1.12

Type: remote

Family: CGI abuses

Published: 2013/02/04

Updated: 2019/12/04

Dependencies: 18297

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2013-0235

CVSS v2.0

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: www/PHP, installed_sw/WordPress, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2013/01/24

Vulnerability Publication Date: 2012/12/11

Reference Information

CVE: CVE-2013-0235, CVE-2013-0236, CVE-2013-0237

BID: 57554, 57555

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990