Ubuntu 12.04 LTS / 12.10 : libvirt vulnerabilities (USN-1708-1)

High Nessus Plugin ID 64289


The remote Ubuntu host is missing one or more security-related patches.


Wenlong Huang discovered that libvirt incorrectly handled certain RPC calls. A remote attacker could exploit this and cause libvirt to crash, resulting in a denial of service. This issue only affected Ubuntu 12.04 LTS. (CVE-2012-4423)

Tingting Zheng discovered that libvirt incorrectly handled cleanup under certain error conditions. A remote attacker could exploit this and cause libvirt to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2013-0170).

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected libvirt-bin and / or libvirt0 packages.

Plugin Details

Severity: High

ID: 64289

File Name: ubuntu_USN-1708-1.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2013/01/30

Modified: 2016/05/25

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:libvirt-bin, p-cpe:/a:canonical:ubuntu_linux:libvirt0, cpe:/o:canonical:ubuntu_linux:12.04:-:lts, cpe:/o:canonical:ubuntu_linux:12.10

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/01/29

Reference Information

CVE: CVE-2012-4423, CVE-2013-0170

BID: 55541, 57578

OSVDB: 86205, 89644

USN: 1708-1