RHEL 5 : kvm (RHSA-2010:0126)

High Nessus Plugin ID 63920


The remote Red Hat host is missing one or more security updates.


Updated kvm packages that fix two security issues and two bugs are now available for Red Hat Enterprise Linux 5.

This update has been rated as having important security impact by the Red Hat Security Response Team.

KVM (Kernel-based Virtual Machine) is a full virtualization solution for Linux on AMD64 and Intel 64 systems. KVM is a Linux kernel module built for the standard Red Hat Enterprise Linux kernel.

A flaw was found in the way the x86 emulator loaded segment selectors (used for memory segmentation and protection) into segment registers.
In some guest system configurations, an unprivileged guest user could leverage this flaw to crash the guest or possibly escalate their privileges within the guest. (CVE-2010-0419)

The x86 emulator implementation was missing a check for the Current Privilege Level (CPL) while accessing debug registers. An unprivileged user in a guest could leverage this flaw to crash the guest.

This update also fixes the following bugs :

With Red Hat Enterprise Virtualization, the virtio_blk_dma_restart_bh() function was previously used to handle write errors; however, a bug fix provided by the RHSA-2009:1659 update meant that read errors would also have to be handled by this function.
The function was not updated for this, causing read errors to be resubmitted as writes. This caused guest image corruption in some cases.

Additionally, the return values of the bdrv_aio_write() and bdrv_aio_read() functions were ignored. If an immediate failure occurred in one of these functions, errors would be missed and the guest could hang or read corrupted data. (BZ#562776)

All KVM users should upgrade to these updated packages, which contain backported patches to resolve these issues. Note: The procedure in the Solution section must be performed before this update will take effect.


Update the affected packages.

See Also




Plugin Details

Severity: High

ID: 63920

File Name: redhat-RHSA-2010-0126.nasl

Version: $Revision: 1.17 $

Type: local

Agent: unix

Published: 2013/01/24

Modified: 2017/01/04

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.1

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:kmod-kvm, p-cpe:/a:redhat:enterprise_linux:kvm, p-cpe:/a:redhat:enterprise_linux:kvm-qemu-img, p-cpe:/a:redhat:enterprise_linux:kvm-tools, cpe:/o:redhat:enterprise_linux:5, cpe:/o:redhat:enterprise_linux:5.4

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2010/03/01

Reference Information

CVE: CVE-2009-3722, CVE-2010-0419

BID: 37221

OSVDB: 62845

RHSA: 2010:0126

CWE: 264