Google Chrome < 24.0.1312.56 Multiple Vulnerabilities

High Nessus Plugin ID 63645


The remote host contains a web browser that is affected by multiple vulnerabilities.


The version of Google Chrome installed on the remote host is earlier than 24.0.1312.56 and is, therefore, affected by the following vulnerabilities :

- A use-after-free vulnerability exists related to font handling and canvas. (CVE-2013-0839)

- An error exists related to URL validation and the opening of new browser windows. (CVE-2013-0840)

- An array index is not properly checked in relation to content blocking. (CVE-2013-0841)

- An unspecified error exists related to handling null characters in embedded paths. (CVE-2013-0842)

Successful exploitation of some of these issues could lead to an application crash or even allow arbitrary code execution, subject to the user's privileges.


Upgrade to Google Chrome 24.0.1312.56 or later.

See Also

Plugin Details

Severity: High

ID: 63645

File Name: google_chrome_24_0_1312_56.nasl

Version: $Revision: 1.12 $

Type: local

Agent: windows

Family: Windows

Published: 2013/01/22

Modified: 2016/05/20

Dependencies: 34196

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/01/22

Vulnerability Publication Date: 2013/01/22

Reference Information

CVE: CVE-2013-0839, CVE-2013-0840, CVE-2013-0841, CVE-2013-0842

BID: 59680, 59681, 59682, 59683

OSVDB: 89469, 89470, 89503, 89504