PHP 5.4.x < 5.4.11 cURL X.509 Certificate Domain Name Matching MiTM Weakness

Medium Nessus Plugin ID 63622

Synopsis

The remote web server uses a version of PHP that is potentially vulnerable to man-in-the-middle attacks.

Description

According to its banner, the version of PHP 5.4.x installed on the remote host is prior to 5.4.11. It is, therefore, potentially affected by a weakness in the cURL extension that can allow SSL spoofing and man-in-the-middle attacks.

When attempting to validate a certificate, the cURL library (libcurl) fails to verify that a server hostname matches a domain name in an X.509 certificate's 'Subject Common Name' (CN) or 'SubjectAltName'.

Note that this plugin does not attempt to verify whether the PHP install has been built with the cURL extention but instead relies only on PHP's self-reported version number.

Solution

Upgrade to PHP version 5.4.11 or later.

See Also

http://www.php.net/ChangeLog-5.php#5.4.11

https://bugs.php.net/bug.php?id=63352

https://bugs.php.net/bug.php?id=63795

Plugin Details

Severity: Medium

ID: 63622

File Name: php_5_4_11.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 2013/01/18

Updated: 2018/08/13

Dependencies: 48243

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, Settings/ParanoidReport

Patch Publication Date: 2013/01/17

Vulnerability Publication Date: 2013/01/17