Nagios Core history.cgi Multiple Parameter Buffer Overflow

high Nessus Plugin ID 63563
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server hosts an application affected by a buffer overflow vulnerability.

Description

The remote web server hosts a version of Nagios Core that is affected by a buffer overflow vulnerability. By sending a specially crafted request using the 'host_name' or 'svc_description' parameter to 'history.cgi', a remote attacker may be able to execute arbitrary code or trigger a denial of service condition.

Solution

Upgrade to Nagios Core 3.4.4 or later.

See Also

https://pastebin.com/FJUNyTaj

https://www.nagios.org/projects/nagios-core/history/3x/

Plugin Details

Severity: High

ID: 63563

File Name: nagios_core_344.nasl

Version: 1.11

Type: remote

Family: CGI abuses

Published: 1/16/2013

Updated: 1/19/2021

Dependencies: nagios_core_detect.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: High

Score: 7.3

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:nagios:nagios

Required KB Items: Settings/ParanoidReport

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 1/12/2013

Vulnerability Publication Date: 12/9/2012

Exploitable With

Core Impact

Metasploit (Nagios3 history.cgi Host Command Execution)

Reference Information

CVE: CVE-2012-6096

BID: 56879

EDB-ID: 24084