Samba 4.x < 4.0.1 AD DC LDAP Directory Objects Security Bypass

Low Nessus Plugin ID 63561


The remote Samba server is affected by a security bypass vulnerability.


According to its banner, the version of Samba 4.x running on the remote host is earlier than 4.0.1, and is, therefore, potentially affected by a security bypass vulnerability.

When acting as an Active Directory (AD) Domain Controller (DC), the application can improperly grant write access to an LDAP directory object or its attributes improperly. This error can be triggered when a user or group is granted any access to an LDAP directory object based on objectClass or is granted write access to any attribute on the object.

Note that, by default, the application does not make 'authenticated users' a part of the 'pre-windows 2000 compatible access' group, which is the group that typically receives the problematic per-objectClass permission.

Further note that Nessus has not actually tried to exploit this issue or otherwise determine if the patch or workaround has been applied.


Either install the patch referenced in the project's advisory or upgrade to 4.0.1 or later.

See Also

Plugin Details

Severity: Low

ID: 63561

File Name: samba_4_0_1.nasl

Version: $Revision: 1.7 $

Type: remote

Family: Misc.

Published: 2013/01/16

Modified: 2016/06/16

Dependencies: 10785

Risk Information

Risk Factor: Low


Base Score: 3.5

Temporal Score: 3

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/01/15

Vulnerability Publication Date: 2013/01/15

Reference Information

CVE: CVE-2013-0172

BID: 57329

OSVDB: 89180