Firefox ESR < 17.0.2 Multiple Vulnerabilities (Mac OS X)

High Nessus Plugin ID 63544


The remote Mac OS X host contains a web browser that is affected by multiple vulnerabilities.


The installed version of Firefox ESR is earlier than 17.0.2 and thus, is potentially affected by the following security issues :

- Two intermediate certificates were improperly issued by TURKTRUST certificate authority. (CVE-2013-0743)

- A use-after-free error exists related to displaying HTML tables with many columns and column groups.

- An error exists related to the 'AutoWrapperChanger' class that does not properly manage objects during garbage collection. (CVE-2012-0745)

- An error exists related to 'jsval', 'quickstubs', and compartmental mismatches that could lead to potentially exploitable crashes. (CVE-2013-0746)

- Errors exist related to events in the plugin handler that could allow same-origin policy bypass.

- An error related to the 'toString' method of XBL objects could lead to address information leakage.

- A buffer overflow exists related to JavaScript string concatenation. (CVE-2013-0750)
- An error exists related to multiple XML bindings with SVG content, contained in XBL files. (CVE-2013-0752)

- A use-after-free error exists related to 'XMLSerializer' and 'serializeToStream'.

- A use-after-free error exists related to garbage collection and 'ListenManager'. (CVE-2013-0754)

- A use-after-free error exists related to the 'Vibrate' library and 'domDoc'. (CVE-2013-0755)

- A use-after-free error exists related to JavaScript 'Proxy' objects. (CVE-2013-0756)
- 'Chrome Object Wrappers' (COW) can be bypassed by changing object prototypes, which could allow arbitrary code execution. (CVE-2013-0757)

- An error related to SVG elements and plugins could allow privilege escalation. (CVE-2013-0758)

- An error exists related to the address bar that could allow URL spoofing attacks. (CVE-2013-0759)

- An error exists related to SSL and threading that could result in potentially exploitable crashes.

- An error exists related to 'Canvas' and bad height or width values passed to it from HTML. (CVE-2013-0768)


Upgrade to Firefox 17.0.2 ESR or later.

See Also

Plugin Details

Severity: High

ID: 63544

File Name: macosx_firefox_17_0_2.nasl

Version: $Revision: 1.16 $

Type: local

Agent: macosx

Published: 2013/01/15

Modified: 2017/05/16

Dependencies: 55417

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: MacOSX/Firefox/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/01/08

Vulnerability Publication Date: 2013/01/08

Exploitable With

Core Impact

Metasploit (Firefox 17.0.1 Flash Privileged Code Injection)

Reference Information

CVE: CVE-2013-0744, CVE-2013-0745, CVE-2013-0746, CVE-2013-0747, CVE-2013-0748, CVE-2013-0750, CVE-2013-0752, CVE-2013-0753, CVE-2013-0754, CVE-2013-0755, CVE-2013-0756, CVE-2013-0757, CVE-2013-0758, CVE-2013-0759, CVE-2013-0764, CVE-2013-0768

BID: 57204, 57209, 57211, 57213, 57215, 57217, 57218, 57228, 57232, 57234, 57235, 57236, 57238, 57240, 57241, 57244, 57258

OSVDB: 89008, 89009, 89010, 89012, 89013, 89014, 89015, 89016, 89017, 89018, 89019, 89020, 89021, 89022, 89023, 89024