Firefox < 17.0.1 Multiple Vulnerabilities (Mac OS X)

High Nessus Plugin ID 63543

Synopsis

The remote Mac OS X host contains a web browser that is affected by multiple vulnerabilities.

Description

The installed version of Firefox is earlier than 17.0.1 and thus, is potentially affected by the following security issues :

- An unspecified memory corruption issue exists.
(CVE-2013-0749, CVE-2013-0769)

- Multiple, unspecified use-after-free, out-of-bounds read and buffer overflow errors exist. (CVE-2013-0761, CVE-2013-0762, CVE-2013-0763, CVE-2013-0766, CVE-2013-0767, CVE-2013-0771)

Solution

Upgrade to Firefox 17.0.1 / 17.0.1 ESR or later.

See Also

https://www.mozilla.org/en-US/security/advisories/mfsa2013-01/

https://www.mozilla.org/en-US/security/advisories/mfsa2013-02/

Plugin Details

Severity: High

ID: 63543

File Name: macosx_firefox_17_0_1.nasl

Version: 1.10

Type: local

Agent: macosx

Published: 2013/01/15

Updated: 2018/07/14

Dependencies: 55417

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: MacOSX/Firefox/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/01/08

Vulnerability Publication Date: 2013/01/08

Reference Information

CVE: CVE-2013-0749, CVE-2013-0761, CVE-2013-0762, CVE-2013-0763, CVE-2013-0766, CVE-2013-0767, CVE-2013-0769, CVE-2013-0771

BID: 57193, 57194, 57195, 57196, 57197, 57198, 57203, 57205