Fedora 17 : pl-6.0.2-4.fc17 (2013-0211)

High Nessus Plugin ID 63528


The remote Fedora host is missing a security update.


Fix two buffer overflows when expanding file name glob (CVE-2012-6090) and when canonizing path (CVE-2012-6089).

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected pl package.

See Also



Plugin Details

Severity: High

ID: 63528

File Name: fedora_2013-0211.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2013/01/15

Modified: 2015/10/19

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:pl, cpe:/o:fedoraproject:fedora:17

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2013/01/05

Reference Information

CVE: CVE-2012-6089, CVE-2012-6090

FEDORA: 2013-0211