Debian DSA-2606-1 : proftpd-dfsg - symlink race

Low Nessus Plugin ID 63512

Synopsis

The remote Debian host is missing a security-related update.

Description

It has been discovered that in ProFTPd, an FTP server, an attacker on the same physical host as the server may be able to perform a symlink attack allowing to elevate privileges in some configurations.

Solution

Upgrade the proftpd-dfsg packages.

For the stable distribution (squeeze), this problem has been fixed in version 1.3.3a-6squeeze6.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=697524

https://packages.debian.org/source/squeeze/proftpd-dfsg

https://www.debian.org/security/2013/dsa-2606

Plugin Details

Severity: Low

ID: 63512

File Name: debian_DSA-2606.nasl

Version: 1.9

Type: local

Agent: unix

Published: 2013/01/14

Updated: 2020/03/12

Dependencies: 12634

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 1.2

Temporal Score: 0.9

Vector: CVSS2#AV:L/AC:H/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:proftpd-dfsg, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/01/13

Reference Information

CVE: CVE-2012-6095

BID: 57172

DSA: 2606