VLC < 2.0.5 Multiple Vulnerabilities

High Nessus Plugin ID 63381

Synopsis

The remote Windows host contains a media player that is affected by multiple vulnerabilities.

Description

The version of VLC media player installed on the remote host is earlier than 2.0.5. It is, therefore, reportedly affected by the following vulnerabilities :

- An error exists in the file 'modules/codec/subsdec.c' ('libsubsdec_plugin.dll') that does not properly validate input and can allow a buffer overflow. Opening a specially crafted file can result in the execution of arbitrary code. Note that the subtitles feature must be enabled for successful exploitation.

- An error exists related to the 'freetype' renderer that does not properly validate input and can allow a buffer overflow. Opening a specially crafted file can result in the execution of arbitrary code.

- Unspecified errors exist related to 'libaiff_plugin.dll' and to the 'SWF' demuxer that have unspecified impact.

Solution

Upgrade to VLC version 2.0.5 or later. Alternatively, remove any affected plugin files from VLC's plugins directory.

See Also

https://securitytracker.com/id/1027929

http://www.videolan.org/security/sa1301.html

http://www.nessus.org/u?4cd2e15e

http://www.videolan.org/vlc/releases/2.0.5.html

Plugin Details

Severity: High

ID: 63381

File Name: vlc_2_0_5.nasl

Version: 1.7

Type: local

Agent: windows

Family: Windows

Published: 2013/01/04

Updated: 2018/11/15

Dependencies: 31852

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Required KB Items: SMB/VLC/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/12/15

Vulnerability Publication Date: 2012/12/07

Reference Information

CVE: CVE-2013-1868

BID: 57079