Debian DSA-2592-1 : elinks - programming error

Medium Nessus Plugin ID 63342

Synopsis

The remote Debian host is missing a security-related update.

Description

Marko Myllynen discovered that ELinks, a powerful text-mode browser, incorrectly delegates user credentials during GSS-Negotiate.

Solution

Upgrade the elinks packages.

For the stable distribution (squeeze), this problem has been fixed in version 0.12~pre5-2+squeeze1. Since the initial Squeeze release, XULRunner needed to be updated and the version currently in the archive is incompatible with ELinks. As such, JavaScript support needed to be disabled (only a small subset of typical functionality was supported anyway). It will likely be re-enabled in a later point update.

See Also

https://packages.debian.org/source/squeeze/elinks

https://www.debian.org/security/2012/dsa-2592

Plugin Details

Severity: Medium

ID: 63342

File Name: debian_DSA-2592.nasl

Version: 1.7

Type: local

Agent: unix

Published: 2012/12/28

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.1

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:elinks, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2012/12/28

Reference Information

CVE: CVE-2012-4545

DSA: 2592