Drupal 6.x < 6.27 / 7.x < 7.18 Multiple Vulnerabilities

Medium Nessus Plugin ID 63324


The remote web server is running a PHP application that is affected by multiple vulnerabilities.


The remote web server is running a version of Drupal that is 6.x prior to 6.27 or 7.x prior to 7.18. It is, therefore, potentially affected by multiple vulnerabilities :

- An access bypass vulnerability exists that allows search results to improperly display information about blocked users. (CVE-2012-5651)

- Version 6.x is affected by an information disclosure vulnerability that allows information about uploaded files to be displayed in RSS feeds and search results for users that do not have the 'view uploaded files' permission. (CVE-2012-5652)

- An arbitrary code execution vulnerability exists due to a failure to properly verify user-uploaded files. A remote, authenticated attacker, using a specially named PHP file, can bypass input validation checks, and the uploaded file can then be executed with the privileges of the web server user. (CVE-2012-5653)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to version 6.27 / 7.18 or later.

See Also


Plugin Details

Severity: Medium

ID: 63324

File Name: drupal_6_27.nasl

Version: 1.10

Type: remote

Family: CGI abuses

Published: 2012/12/21

Updated: 2018/11/28

Dependencies: 18638

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: www/PHP, installed_sw/Drupal, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/12/19

Vulnerability Publication Date: 2012/12/19

Reference Information

CVE: CVE-2012-5651, CVE-2012-5652, CVE-2012-5653

BID: 56993