Drupal 6.x < 6.27 / 7.x < 7.18 Multiple Vulnerabilities

medium Nessus Plugin ID 63324
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is running a PHP application that is affected by multiple vulnerabilities.

Description

The remote web server is running a version of Drupal that is 6.x prior to 6.27 or 7.x prior to 7.18. It is, therefore, potentially affected by multiple vulnerabilities :

- An access bypass vulnerability exists that allows search results to improperly display information about blocked users. (CVE-2012-5651)

- Version 6.x is affected by an information disclosure vulnerability that allows information about uploaded files to be displayed in RSS feeds and search results for users that do not have the 'view uploaded files' permission. (CVE-2012-5652)

- An arbitrary code execution vulnerability exists due to a failure to properly verify user-uploaded files. A remote, authenticated attacker, using a specially named PHP file, can bypass input validation checks, and the uploaded file can then be executed with the privileges of the web server user. (CVE-2012-5653)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to version 6.27 / 7.18 or later.

See Also

http://www.nessus.org/u?47c23a63

Plugin Details

Severity: Medium

ID: 63324

File Name: drupal_6_27.nasl

Version: 1.11

Type: remote

Family: CGI abuses

Published: 12/21/2012

Updated: 1/19/2021

Dependencies: drupal_detect.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 5.8

CVSS v2

Risk Factor: Medium

Base Score: 6

Temporal Score: 4.4

Vector: AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: www/PHP, installed_sw/Drupal, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 12/19/2012

Vulnerability Publication Date: 12/19/2012

Reference Information

CVE: CVE-2012-5651, CVE-2012-5652, CVE-2012-5653

BID: 56993