lighttpd 1.4.31 http_request_split_value Function Header Handling DoS

Medium Nessus Plugin ID 63094


The remote web server is affected by a denial of service vulnerability.


According to its banner, the version of lighttpd running on the remote host is 1.4.31. It is, therefore, affected by a denial of service vulnerability. An error in the http_request_split_value() function in 'src/request.c' can cause the application to enter an endless loop when handling specially crafted 'Connection' header requests.

Note that Nessus has not tested for this issue but has instead relied only on the version in the server's banner.


Upgrade to lighttpd version 1.4.32 or later. Alternatively, apply the vendor-supplied patch.

See Also

Plugin Details

Severity: Medium

ID: 63094

File Name: lighttpd_1_4_32.nasl

Version: $Revision: 1.9 $

Type: remote

Family: Web Servers

Published: 2012/11/29

Modified: 2018/02/07

Dependencies: 106628

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 4.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:lighttpd:lighttpd

Required KB Items: installed_sw/lighttpd, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/11/21

Vulnerability Publication Date: 2012/11/21

Reference Information

CVE: CVE-2012-5533

BID: 56619

OSVDB: 87623

EDB-ID: 22902