VMware Player 4.x < 4.0.5 Multiple Vulnerabilities (VMSA-2012-0015)

High Nessus Plugin ID 63076


The remote host has a virtualization application that is affected by multiple vulnerabilities.


The VMware Player 4.x install detected on the remote host is earlier than 4.0.5 and is, therefore, potentially affected by the following vulnerabilities :

- Certain processes, when created, have weak security permissions assigned. It is possible to commandeer these process threads, which could result in elevation of privileges in the context of the host. (CVE-2012-5458)

- A DLL binary planning vulnerability exists that could be exploited by an attacker to execute arbitrary code on the remote host. (CVE-2012-5459)


Upgrade to VMware Player 4.0.5 or later.

See Also



Plugin Details

Severity: High

ID: 63076

File Name: vmware_player_multiple_vmsa_2012_0015.nasl

Version: $Revision: 1.5 $

Type: local

Agent: windows

Family: Windows

Published: 2012/11/28

Modified: 2014/01/26

Dependencies: 31728

Risk Information

Risk Factor: High


Base Score: 8.3

Temporal Score: 6.1

Vector: CVSS2#AV:A/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:player

Required KB Items: SMB/Registry/Enumerated, VMware/Player/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/11/08

Vulnerability Publication Date: 2012/11/08

Reference Information

CVE: CVE-2012-5458, CVE-2012-5459

BID: 56469, 56470

OSVDB: 87118, 87119

VMSA: 2012-0015