Mandriva Linux Security Advisory : libtiff (MDVSA-2012:174)

Medium Nessus Plugin ID 63017


The remote Mandriva Linux host is missing one or more security updates.


Multiple vulnerabilities was found and corrected in libtiff :

Heap-based buffer overflow in tif_pixarlog.c in LibTIFF before 4.0.3 allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a crafted TIFF image using the PixarLog Compression format (CVE-2012-4447).

ppm2tiff does not check the return value of the TIFFScanlineSize function, which allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted PPM image that triggers an integer overflow, a zero-memory allocation, and a heap-based buffer overflow (CVE-2012-4564).

The updated packages have been patched to correct these issues.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 63017

File Name: mandriva_MDVSA-2012-174.nasl

Version: $Revision: 1.7 $

Type: local

Published: 2012/11/23

Modified: 2013/10/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64tiff-devel, p-cpe:/a:mandriva:linux:lib64tiff-static-devel, p-cpe:/a:mandriva:linux:lib64tiff3, p-cpe:/a:mandriva:linux:libtiff-devel, p-cpe:/a:mandriva:linux:libtiff-progs, p-cpe:/a:mandriva:linux:libtiff-static-devel, p-cpe:/a:mandriva:linux:libtiff3, cpe:/o:mandriva:linux:2011

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/11/22

Reference Information

CVE: CVE-2012-4447, CVE-2012-4564

BID: 55673, 56372

MDVSA: 2012:174