Apache Tomcat 7.0.x < 7.0.28 Multiple DoS

Medium Nessus Plugin ID 62985

Synopsis

The remote Apache Tomcat server is affected by multiple remote denial of service vulnerabilities.

Description

According to its self-reported version number, the instance of Apache Tomcat 7.0 listening on the remote host is prior to 7.0.28. It is, therefore, affected by the following vulnerabilities :

- A flaw exists within the parseHeaders() function that allows an attacker, via a crafted header, to cause a remote denial of service. (CVE-2012-2733)

- An error exists related to the 'NIO' connector when HTTPS and 'sendfile' are enabled that can force the application into an infinite loop. (CVE-2012-4534)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 7.0.28 or later.

See Also

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.28

https://seclists.org/fulldisclosure/2012/Dec/72

Plugin Details

Severity: Medium

ID: 62985

File Name: tomcat_7_0_28.nasl

Version: 1.18

Type: remote

Family: Web Servers

Published: 2012/11/21

Updated: 2018/11/15

Dependencies: 39446

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/07/02

Vulnerability Publication Date: 2012/07/02

Reference Information

CVE: CVE-2012-2733, CVE-2012-4534

BID: 56402, 56813