Scientific Linux Security Update : kernel on SL5.x i386/x86_64

High Nessus Plugin ID 62924

Synopsis

The remote Scientific Linux host is missing one or more security updates.

Description

The kernel packages contain the Linux kernel, the core of any Linux operating system.

This update fixes the following security issue :

- It was found that a previous update did not correctly fix the CVE-2009-4307 issue, a divide-by-zero flaw in the ext4 file system code. A local, unprivileged user with the ability to mount an ext4 file system could use this flaw to cause a denial of service. (CVE-2012-2100, Low)

This update also fixes several bugs.

The system must be rebooted for this update to take effect.

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?01eb32dd

Plugin Details

Severity: High

ID: 62924

File Name: sl_20121113_kernel_on_SL5_x.nasl

Version: 1.7

Type: local

Agent: unix

Published: 2012/11/15

Updated: 2018/12/31

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C

Vulnerability Information

CPE: x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2012/11/13

Reference Information

CVE: CVE-2009-4307, CVE-2012-2100

CWE: 189