Flash Player for Mac <= / 11.4.402.287 Multiple Vulnerabilities (APSB12-24)

High Nessus Plugin ID 62838


The remote Mac OS X host has a browser plugin that is affected by multiple vulnerabilities.


According to its version, the instance of Flash Player installed on the remote Mac OS X host is 11.x equal to or earlier than 11.4.402.287, or 10.x equal to or earlier than It is, therefore, potentially affected by multiple vulnerabilities :

- Several unspecified issues exist that can lead to buffer overflows and arbitrary code execution. (CVE-2012-5274, CVE-2012-5275, CVE-2012-5276, CVE-2012-5277, CVE-2012-5280)

- An unspecified security bypass issue exists that can lead to arbitrary code execution. (CVE-2012-5278)

- An unspecified issue exists that can lead to memory corruption and arbitrary code execution. (CVE-2012-5279)


Upgrade to Adobe Flash Player version / 11.5.502.110 or later.

See Also


Plugin Details

Severity: High

ID: 62838

File Name: macosx_flash_player_11_5_502_110.nasl

Version: $Revision: 1.9 $

Type: local

Agent: macosx

Published: 2012/11/07

Modified: 2016/05/17

Dependencies: 53914

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: MacOSX/Flash_Player/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/11/06

Vulnerability Publication Date: 2012/11/06

Reference Information

CVE: CVE-2012-5274, CVE-2012-5275, CVE-2012-5276, CVE-2012-5277, CVE-2012-5278, CVE-2012-5279, CVE-2012-5280

BID: 56542, 56543, 56544, 56545, 56546, 56547, 56554

OSVDB: 87064, 87065, 87066, 87067, 87068, 87069, 87070