Exim 4.70 - 4.80 DKIM DNS Record Parsing Remote Buffer Overflow

High Nessus Plugin ID 62734


The remote mail server is potentially affected by a buffer overflow vulnerability.


According to its banner, the version of Exim running on the remote host is between 4.70 and 4.80 inclusive. It therefore is potentially affected by a remote, heap-based buffer overflow vulnerability when decoding DKIM (DomainKeys Identified Mail) DNS records that can be triggered by a specially crafted email sent from a domain under the attacker's control.

By exploiting this flaw, a remote, unauthenticated attacker could execute arbitrary code on the remote host subject to the privileges of the user running the affected application.

Note that this issue is only exploitable when exim is built with DKIM support, which is true by default, and has not been disabled. Note too that Nessus has not checked whether either condition is true.


Upgrade to Exim 4.80.1 or later.

See Also



Plugin Details

Severity: High

ID: 62734

File Name: exim_4_80_1.nasl

Version: $Revision: 1.4 $

Type: remote

Published: 2012/10/29

Modified: 2014/05/24

Dependencies: 10263

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:exim:exim

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/10/26

Vulnerability Publication Date: 2012/10/26

Reference Information

CVE: CVE-2012-5671

BID: 56285

OSVDB: 86616