Exim 4.70 - 4.80 DKIM DNS Record Parsing Remote Buffer Overflow

medium Nessus Plugin ID 62734


The remote mail server is potentially affected by a buffer overflow vulnerability.


According to its banner, the version of Exim running on the remote host is between 4.70 and 4.80 inclusive. It therefore is potentially affected by a remote, heap-based buffer overflow vulnerability when decoding DKIM (DomainKeys Identified Mail) DNS records that can be triggered by a specially crafted email sent from a domain under the attacker's control.

By exploiting this flaw, a remote, unauthenticated attacker could execute arbitrary code on the remote host subject to the privileges of the user running the affected application.

Note that this issue is only exploitable when exim is built with DKIM support, which is true by default, and has not been disabled. Note too that Nessus has not checked whether either condition is true.


Upgrade to Exim 4.80.1 or later.

See Also



Plugin Details

Severity: Medium

ID: 62734

File Name: exim_4_80_1.nasl

Version: 1.6

Type: remote

Published: 10/29/2012

Updated: 12/4/2019

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2012-5671

Vulnerability Information

CPE: cpe:/a:exim:exim

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 10/26/2012

Vulnerability Publication Date: 10/26/2012

Reference Information

CVE: CVE-2012-5671

BID: 56285