Wireshark 1.8.x < 1.8.3 Multiple Vulnerabilities

Medium Nessus Plugin ID 62478


The remote Windows host contains an application that is affected by multiple vulnerabilities.


The installed version of Wireshark 1.8 is earlier than 1.8.3. It thus is affected by the following vulnerabilities :

- A malformed packet can cause the 'DRDA' and 'HSRP' dissectors to enter an infinite loop, thereby consuming excessive CPU resources. (CVE-2012-3548, CVE-2012-5237)

- A malformed packet can cause the 'PPP' dissector to crash the application. (CVE-2012-5238)

- A malformed packet can trigger a buffer overflow in the 'LDP' dissector, which results in an application crash.


Upgrade to Wireshark version 1.8.3 or later.

See Also






Plugin Details

Severity: Medium

ID: 62478

File Name: wireshark_1_8_3.nasl

Version: $Revision: 1.5 $

Type: local

Agent: windows

Family: Windows

Published: 2012/10/10

Modified: 2013/05/22

Dependencies: 34112

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/10/02

Vulnerability Publication Date: 2012/06/01

Exploitable With

Core Impact

Reference Information

CVE: CVE-2012-3548, CVE-2012-5237, CVE-2012-5238, CVE-2012-5240

BID: 55284, 55754

OSVDB: 85092, 85883, 85884, 85885