Mandriva Linux Security Advisory : ghostscript (MDVSA-2012:151-1)

Medium Nessus Plugin ID 62445


The remote Mandriva Linux host is missing one or more security updates.


A security issue was identified and fixed in ghostscript :

An integer overflow flaw, leading to a heap-based buffer overflow, was found in Ghostscript's International Color Consortium Format library (icclib). An attacker could create a specially crafted PostScript or PDF file with embedded images that would cause Ghostscript to crash or, potentially, execute arbitrary code with the privileges of the user running Ghostscript (CVE-2012-4405).

The updated packages have been patched to correct this issue.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 62445

File Name: mandriva_MDVSA-2012-151.nasl

Version: $Revision: 1.6 $

Type: local

Published: 2012/10/06

Modified: 2014/08/16

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:ghostscript, p-cpe:/a:mandriva:linux:ghostscript-X, p-cpe:/a:mandriva:linux:ghostscript-common, p-cpe:/a:mandriva:linux:ghostscript-doc, p-cpe:/a:mandriva:linux:ghostscript-dvipdf, p-cpe:/a:mandriva:linux:ghostscript-module-X, p-cpe:/a:mandriva:linux:lib64gs-devel, p-cpe:/a:mandriva:linux:lib64gs9, p-cpe:/a:mandriva:linux:lib64ijs-devel, p-cpe:/a:mandriva:linux:lib64ijs1, p-cpe:/a:mandriva:linux:libgs-devel, p-cpe:/a:mandriva:linux:libgs9, p-cpe:/a:mandriva:linux:libijs-devel, p-cpe:/a:mandriva:linux:libijs1, cpe:/o:mandriva:linux:2011

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/10/05

Reference Information

CVE: CVE-2012-4405

BID: 55494

MDVSA: 2012:151-1