Mandriva Linux Security Advisory : freeradius (MDVSA-2012:159)

Medium Nessus Plugin ID 62425


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability has been found and corrected in freeradius :

Stack-based buffer overflow in the cbtls_verify function in FreeRADIUS 2.1.10 through 2.1.12, when using TLS-based EAP methods, allows remote attackers to cause a denial of service (server crash) and possibly execute arbitrary code via a long not after timestamp in a client certificate (CVE-2012-3547).

The updated packages have been patched to correct this issue.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 62425

File Name: mandriva_MDVSA-2012-159.nasl

Version: $Revision: 1.5 $

Type: local

Published: 2012/10/04

Modified: 2013/10/24

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:freeradius, p-cpe:/a:mandriva:linux:freeradius-krb5, p-cpe:/a:mandriva:linux:freeradius-ldap, p-cpe:/a:mandriva:linux:freeradius-mysql, p-cpe:/a:mandriva:linux:freeradius-postgresql, p-cpe:/a:mandriva:linux:freeradius-sqlite, p-cpe:/a:mandriva:linux:freeradius-unixODBC, p-cpe:/a:mandriva:linux:freeradius-web, p-cpe:/a:mandriva:linux:lib64freeradius-devel, p-cpe:/a:mandriva:linux:lib64freeradius1, p-cpe:/a:mandriva:linux:libfreeradius-devel, p-cpe:/a:mandriva:linux:libfreeradius1, cpe:/o:mandriva:linux:2011

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/10/03

Reference Information

CVE: CVE-2012-3547

BID: 55483

MDVSA: 2012:159