SumatraPDF < 2.1 Multiple Vulnerabilities

High Nessus Plugin ID 62390


The remote Windows host has a PDF reader installed that is affected by multiple vulnerabilities.


The version of SumatraPDF installed on the remote Windows host is earlier than 2.1. As such, it is potentially affected by multiple memory corruption vulnerabilities. By tricking a user into opening a specially crafted PDF file, a remote, unauthenticated attacker could execute arbitrary code on the remote host, subject to the privileges of the user running the affected application.


Upgrade to SumatraPDF 2.1 or later.

See Also

Plugin Details

Severity: High

ID: 62390

File Name: sumatra_pdf_21.nasl

Version: $Revision: 1.2 $

Type: local

Agent: windows

Family: Windows

Published: 2012/10/02

Modified: 2012/10/03

Dependencies: 62389

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:krystztof_kowalczyk:sumatrapdf

Required KB Items: SMB/SumatraPDF/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/05/03

Vulnerability Publication Date: 2012/09/18

Reference Information

CVE: CVE-2012-4895, CVE-2012-4896

BID: 55596

OSVDB: 85568, 85569

MSVR: MSVR12-014