GLSA-201209-14 : file: Denial of Service

Medium Nessus Plugin ID 62343


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201209-14 (file: Denial of Service)

Multiple out-of-bounds read errors and invalid pointer dereference errors have been found in cdf.c.
Impact :

A remote attacker could entice a user to open a specially crafted Composite Document File (CDF) using file, possibly resulting in a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All file users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-apps/file-5.11'

See Also

Plugin Details

Severity: Medium

ID: 62343

File Name: gentoo_GLSA-201209-14.nasl

Version: $Revision: 1.5 $

Type: local

Published: 2012/09/27

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:file, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/09/26

Reference Information

CVE: CVE-2012-1571

BID: 52225

GLSA: 201209-14