Google SketchUp < 8.0.14346 Multiple Vulnerabilities

High Nessus Plugin ID 62315


A 3-D modeling application on the remote Windows host is affected by multiple vulnerabilities.


The version of Google SketchUp installed on the remote Windows host is earlier than 8.0.14346. As such, it reportedly is affected by the following vulnerabilities:

- The application fails to handle certain types of '.SKP' files. An attacker can exploit this issue by providing a specially crafted '.SKP' file to the victim that can execute arbitrary code in the context of the application. (CVE-2012-4894)

- An error exists related to the handling of BMP RLE8 compressed textures that could result in application crashes or arbitrary code execution. (CVE-2013-3663)


Upgrade to Google SketchUp 8.0 Maintenance 3 (8.0.14346) or later.

See Also

Plugin Details

Severity: High

ID: 62315

File Name: google_sketchup_8_0_14346.nasl

Version: $Revision: 1.4 $

Type: local

Agent: windows

Family: Windows

Published: 2012/09/26

Modified: 2013/06/20

Dependencies: 56712

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:sketchup

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/05/23

Vulnerability Publication Date: 2012/09/18

Reference Information

CVE: CVE-2012-4894, CVE-2013-3663

BID: 55598, 60251

OSVDB: 85570, 93788

IAVB: 2013-B-0063

MSVR: MSVR12-015