Google Chrome < 22.0.1229.79 Multiple Vulnerabilities

critical Nessus Plugin ID 62313
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host contains a web browser that is affected by multiple vulnerabilities.

Description

The version of Google Chrome installed on the remote host is earlier than 22.0.1229.79 and is, therefore, affected by the following vulnerabilities :

- Out-of-bounds write errors exist related to Skia and the PDF viewer. (CVE-2012-2874, CVE-2012-2883, CVE-2012-2895)

- Various, unspecified errors exist related to the PDF viewer. (CVE-2012-2875)

- A buffer overflow error exists related to 'SSE2' optimizations. (CVE-2012-2876)

- An unspecified error exists related to extensions and modal dialogs that can allow application crashes.
(CVE-2012-2877)

- Use-after-free errors exist related to plugin handling, 'onclick' handling, 'SVG' text references and the PDF viewer. (CVE-2012-2878, CVE-2012-2887, CVE-2012-2888, CVE-2012-2890)

- An error exists related to 'DOM' topology corruption.
(CVE-2012-2879)

- Race conditions exist in the plugin paint buffer.
(CVE-2012-2880)

- 'DOM' tree corruption can occur with plugins.
(CVE-2012-2881)

- A pointer error exists related to 'OGG' container handling. (CVE-2012-2882)

- An out-of-bounds read error exists related to Skia.
(CVE-2012-2884)

- The possibility of a double-free error exists related to application exit. (CVE-2012-2885)

- Universal cross-site scripting issues exist related to the v8 JavaScript engine bindings and frame handling. (CVE-2012-2886, CVE-2012-2889)

- Address information can be leaked via inter process communication (IPC). (CVE-2012-2891)

- A bypass error exists related to pop-up block.
(CVE-2012-2892)

- A double-free error exists related to 'XSL' transforms.
(CVE-2012-2893)

- An error exists related to graphics context handling.
(CVE-2012-2894)

- An unspecified memory corruption issue exists in the Windows 7 kernel, as used by Google Chrome.
(CVE-2012-2897)

Successful exploitation of any of these issues could lead to an application crash or even allow arbitrary code execution, subject to the user's privileges.

Solution

Upgrade to Google Chrome 22.0.1229.79 or later.

See Also

http://www.nessus.org/u?8ccfa44f

Plugin Details

Severity: Critical

ID: 62313

File Name: google_chrome_22_0_1229_79.nasl

Version: 1.17

Type: local

Agent: windows

Family: Windows

Published: 9/26/2012

Updated: 12/4/2019

Dependencies: google_chrome_installed.nasl

Risk Information

CVSS Score Source: CVE-2012-2897

VPR

Risk Factor: High

Score: 8.9

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:*

Required KB Items: SMB/Google_Chrome/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/25/2012

Vulnerability Publication Date: 9/25/2012

Exploitable With

Core Impact

Reference Information

CVE: CVE-2012-2893, CVE-2012-2897, CVE-2012-2889, CVE-2012-2874, CVE-2012-2875, CVE-2012-2876, CVE-2012-2877, CVE-2012-2878, CVE-2012-2879, CVE-2012-2880, CVE-2012-2881, CVE-2012-2882, CVE-2012-2883, CVE-2012-2884, CVE-2012-2885, CVE-2012-2886, CVE-2012-2887, CVE-2012-2888, CVE-2012-2890, CVE-2012-2891, CVE-2012-2892, CVE-2012-2894, CVE-2012-2895

BID: 55676, 56457

CWE: 20, 79, 74, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990