Fedora Extras : mediawiki-1.8.3-7 (2007-005)

High Nessus Plugin ID 62279


The remote Fedora Core host is missing a security update.


An XSS injection vulnerability was located in the AJAX support module, affecting MediaWiki 1.6.x and up when the optional setting $wgUseAjax is enabled.

There is no danger in the default configuration, with $wgUseAjax off.

- Tue Jan 9 2007 Axel Thimm <Axel.Thimm at ATrpms.net> - 1.8.3-7

- Update to 1.8.3.

- Update fixes an XSS injection vulnerability in the AJAX module.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected mediawiki package.

See Also


Plugin Details

Severity: High

ID: 62279

File Name: fedora_extras_2007-005.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2012/09/24

Modified: 2015/10/19

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:mediawiki, cpe:/o:fedoraproject:fedora_core:5, cpe:/o:fedoraproject:fedora_core:6

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2007/01/10