Ubuntu 10.04 LTS / 11.04 / 11.10 / 12.04 LTS : dhcp3, isc-dhcp vulnerability (USN-1571-1)

High Nessus Plugin ID 62180


The remote Ubuntu host is missing one or more security-related patches.


Glen Eustace discovered that the DHCP server incorrectly handled IPv6 expiration times. A remote attacker could use this issue to cause DHCP to crash, resulting in a denial of service. This issue only affected Ubuntu 11.04, Ubuntu 11.10 and Ubuntu 12.04 LTS. (CVE-2012-3955)

Dan Rosenberg discovered that the DHCP AppArmor profile could be escaped by using environment variables. This update mitigates the issue by sanitizing certain variables in the DHCP shell scripts.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

Plugin Details

Severity: High

ID: 62180

File Name: ubuntu_USN-1571-1.nasl

Version: $Revision: 1.10 $

Type: local

Agent: unix

Published: 2012/09/18

Modified: 2016/05/25

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.1

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:dhcp3-client, p-cpe:/a:canonical:ubuntu_linux:dhcp3-server, p-cpe:/a:canonical:ubuntu_linux:isc-dhcp-client, p-cpe:/a:canonical:ubuntu_linux:isc-dhcp-server, cpe:/o:canonical:ubuntu_linux:10.04:-:lts, cpe:/o:canonical:ubuntu_linux:11.04, cpe:/o:canonical:ubuntu_linux:11.10, cpe:/o:canonical:ubuntu_linux:12.04:-:lts

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/09/18

Reference Information

CVE: CVE-2012-3955

BID: 55530

OSVDB: 85424

USN: 1571-1