Fedora 16 : asterisk- (2012-13437)

High Nessus Plugin ID 62154


The remote Fedora host is missing a security update.


The Asterisk Development Team has announced security releases for Certified Asterisk 1.8.11 and Asterisk 1.8 and 10. The available security releases are released as versions 1.8.11-cert7,, 10.7.1, and 10.7.1-digiumphones.

These releases are available for immediate download at http://downloads.asterisk.org/pub/telephony/asterisk/releases

The release of Asterisk 1.8.11-cert7,, 10.7.1, and 10.7.1-digiumphones resolve the following two issues :

- A permission escalation vulnerability in Asterisk Manager Interface. This would potentially allow remote authenticated users the ability to execute commands on the system shell with the privileges of the user running the Asterisk application. Please note that the README-SERIOUSLY.bestpractices.txt file delivered with Asterisk has been updated due to this and other related vulnerabilities fixed in previous versions of Asterisk.

- When an IAX2 call is made using the credentials of a peer defined in a dynamic Asterisk Realtime Architecture (ARA) backend, the ACL rules for that peer are not applied to the call attempt. This allows for a remote attacker who is aware of a peer's credentials to bypass the ACL rules set for that peer.

These issues and their resolutions are described in the security advisories.

For more information about the details of these vulnerabilities, please read security advisories AST-2012-012 and AST-2012-013, which were released at the same time as this announcement.

For a full list of changes in the current releases, please see the ChangeLogs :

http://downloads.asterisk.org/pub/telephony/certified-asterisk/release s/ChangeLog-1.8.11-cert7 http://downloads.asterisk.org/pub/telephony/asterisk/releases/ChangeLo g- http://downloads.asterisk.org/pub/telephony/asterisk/releases/ChangeLo g-10.7.1 http://downloads.asterisk.org/pub/telephony/asterisk/releases/ChangeLo g-10.7.1-digiumphones

The security advisories are available at :

- http://downloads.asterisk.org/pub/security/AST-2012-012.

- http://downloads.asterisk.org/pub/security/AST-2012-01 3.pdf

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected asterisk package.

See Also










Plugin Details

Severity: High

ID: 62154

File Name: fedora_2012-13437.nasl

Version: $Revision: 1.11 $

Type: local

Agent: unix

Published: 2012/09/18

Modified: 2016/05/09

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:asterisk, cpe:/o:fedoraproject:fedora:16

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/09/07

Reference Information

CVE: CVE-2012-2186

BID: 55351

FEDORA: 2012-13437