Scientific Linux Security Update : postgresql on SL5.x i386/x86_64

Medium Nessus Plugin ID 62109


The remote Scientific Linux host is missing one or more security updates.


It was found that the optional PostgreSQL xml2 contrib module allowed local files and remote URLs to be read and written to with the privileges of the database server when parsing Extensible Stylesheet Language Transformations (XSLT). An unprivileged database user could use this flaw to read and write to local files (such as the database's configuration files) and remote URLs they would otherwise not have access to by issuing a specially crafted SQL query. (CVE-2012-3488)

We would like to thank the PostgreSQL project for reporting this issue. Upstream acknowledges Peter Eisentraut as the original reporter.

If the postgresql service is running, it will be automatically restarted after installing this update.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 62109

File Name: sl_20120913_postgresql_on_SL5_x.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2012/09/15

Modified: 2014/08/16

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.9

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:N

Vulnerability Information

CPE: x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2012/09/13

Reference Information

CVE: CVE-2012-3488