Foxit Reader < 5.3 Cross-References RCE

High Nessus Plugin ID 62063


A PDF viewer installed on the remote host is affected by a remote code execution vulnerability.


The version of Foxit Reader installed on the remote Windows host is prior to 5.3. It is, therefore, affected by a memory corruption issue due to the calculation of a negative number during the processing of cross-references. An attacker can exploit this, by tricking a user into opening a crafted PDF file, to execute arbitrary code with the user's privileges.


Upgrade to Foxit Reader version 5.3 or later.

See Also

Plugin Details

Severity: High

ID: 62063

File Name: foxit_reader_5_3.nasl

Version: $Revision: 1.5 $

Type: local

Agent: windows

Family: Windows

Published: 2012/09/12

Modified: 2016/03/07

Dependencies: 32395

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:foxitsoftware:foxit_reader

Required KB Items: installed_sw/Foxit Reader

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/05/03

Vulnerability Publication Date: 2012/08/21

Reference Information

CVE: CVE-2012-4337

BID: 55150

OSVDB: 84808

MSVR: MSVR12-013