Scientific Linux Security Update : ghostscript on SL5.x, SL6.x i386/x86_64

Medium Nessus Plugin ID 62057


The remote Scientific Linux host is missing one or more security updates.


Ghostscript is a set of software that provides a PostScript interpreter, a set of C procedures (the Ghostscript library, which implements the graphics capabilities in the PostScript language) and an interpreter for Portable Document Format (PDF) files.

An integer overflow flaw, leading to a heap-based buffer overflow, was found in Ghostscript's International Color Consortium Format library (icclib). An attacker could create a specially crafted PostScript or PDF file with embedded images that would cause Ghostscript to crash or, potentially, execute arbitrary code with the privileges of the user running Ghostscript. (CVE-2012-4405)

Users of Ghostscript are advised to upgrade to these updated packages, which contain a backported patch to correct this issue.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 62057

File Name: sl_20120911_ghostscript_on_SL5_x.nasl

Version: $Revision: 1.3 $

Type: local

Agent: unix

Published: 2012/09/12

Modified: 2014/08/16

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2012/09/11

Reference Information

CVE: CVE-2012-4405